<!DOCTYPE html>
<html lang="en" dir="ltr">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, minimum-scale=1, user-scalable=no" />
<link rel="shortcut icon" href="https://aldianews.com/sites/default/files/ts8178znqj3awke3f0u4_400x400_1.png" type="image/png" />
<script type="application/ld+json">{
    "@context": "http://schema.org",
    "@graph": [
        {
            "@type": "Article",
            "headline": "Cuban-American Entrepreneur Ray Yabor \u0027exemplifies the American Dream\u0027",
            "name": "Cuban-American Entrepreneur Ray Yabor \u0027exemplifies the American Dream\u0027",
            "description": "Ray Yabor built one of the most successful Latino-owned businesses in Philadelphia and made lasting impact through his work with the Greater Philadelphia Hispanic Chamber of Commerce.",
            "author": [
                {
                    "@type": "Person",
                    "@id": "17392",
                    "name": "Lee Nentwig",
                    "url": "https://aldianews.com/authors/lee-nentwig/17392",
                    "sameAs": "https://www.linkedin.com/in/lee-nentwig-48a311122/"
                }
            ],
            "publisher": {
                "@type": "Organization",
                "@id": "https://aldianews.com",
                "name": "AL DÍA News",
                "url": "https://aldianews.com",
                "sameAs": [
                    "https://www.facebook.com/ALDIANews",
                    "https://instagram.com/aldianews",
                    "https://twitter.com/aldianews",
                    "https://www.youtube.com/user/pontealdiatv"
                ],
                "logo": {
                    "@type": "ImageObject",
                    "url": "https://aldianews.com/sites/default/files/logo2b_0.png"
                }
            },
            "datePublished": "Wed, 06/26/2019 - 6:25pm",
            "dateModified": "Thu, 06/27/2019 - 8:56am",
            "image": {
                "@type": "ImageObject",
                "representativeOfPage": "True",
                "url": "https://aldianews.com/sites/default/files/articles/pg-14-1131.jpg"
            },
            "mainEntityOfPage": "https://aldianews.com/articles/leaders/cuban-american-entrepreneur-ray-yabor-exemplifies-american-dream/55921",
            "about": [
                "Ray Yabor",
                "leaders",
                "Entrepreneur",
                "New American Award",
                "Immigrant Heritage Month"
            ]
        }
    ]
}</script>
<meta name="description" content="Ray Yabor built one of the most successful Latino-owned businesses in Philadelphia and made lasting impact through his work with the Greater Philadelphia Hispanic Chamber of Commerce." />
<meta name="keywords" content="Ray Yabor, leaders, Entrepreneur, New American Award, Immigrant Heritage Month" />
<meta name="abstract" content="Ray Yabor built one of the most successful Latino-owned businesses in Philadelphia and made lasting impact through his work with the Greater Philadelphia Hispanic Chamber of Commerce." />
<meta name="robots" content="follow, index" />
<meta name="news_keywords" content="Ray Yabor, leaders, Entrepreneur, New American Award, Immigrant Heritage Month" />
<meta name="rating" content="general" />
<meta name="rights" content="© AL DÍA News" />
<link rel="image_src" href="https://aldianews.com/sites/default/files/articles/pg-14-1131.jpg" />
<meta name="generator" content="Drupal 7 (https://www.drupal.org)" />
<link rel="canonical" href="https://aldianews.com/articles/leaders/cuban-american-entrepreneur-ray-yabor-exemplifies-american-dream/55921" />
<link rel="shortlink" href="https://aldianews.com/node/55921" />
<meta name="original-source" content="aldianews.com" />
<meta http-equiv="content-language" content="en" />
<meta property="og:site_name" content="AL DÍA News" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://aldianews.com/articles/leaders/cuban-american-entrepreneur-ray-yabor-exemplifies-american-dream/55921" />
<meta property="og:title" content="Cuban-American Entrepreneur Ray Yabor &#039;exemplifies the American Dream&#039;" />
<meta property="og:description" content="Ray Yabor built one of the most successful Latino-owned businesses in Philadelphia and made lasting impact through his work with the Greater Philadelphia Hispanic Chamber of Commerce." />
<meta property="og:updated_time" content="2019-06-27T08:56:07-04:00" />
<meta property="og:image" content="https://aldianews.com/sites/default/files/articles/pg-14-1131.jpg" />
<meta property="og:image:url" content="https://aldianews.com/sites/default/files/articles/pg-14-1131.jpg" />
<meta property="og:image:secure_url" content="https://aldianews.com/sites/default/files/articles/pg-14-1131.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@ALDIANews" />
<meta name="twitter:url" content="https://aldianews.com/articles/leaders/cuban-american-entrepreneur-ray-yabor-exemplifies-american-dream/55921" />
<meta name="twitter:title" content="Cuban-American Entrepreneur Ray Yabor &#039;exemplifies the American Dream&#039;" />
<meta name="twitter:image" content="https://aldianews.com/sites/default/files/articles/pg-14-1131.jpg" />
<meta property="article:author" content="Lee Nentwig" />
<meta name="twitter:image:alt" content="Cuban-American entrepreneur Ray Yabor will be honored by AL DÍA for his contributions to the immigrant community of Philadelphia at The New American reception on Saturday, June 29. Photo: AL DÍA News" />
<meta property="article:section" content="Leaders" />
<meta property="article:tag" content="Ray Yabor" />
<meta property="article:tag" content="leaders" />
<meta property="article:tag" content="Entrepreneur" />
<meta property="article:tag" content="New American Award" />
<meta property="article:tag" content="Immigrant Heritage Month" />
<meta property="article:published_time" content="2019-06-26T18:25:16-04:00" />
<meta property="article:modified_time" content="2019-06-27T08:56:07-04:00" />
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/309686595/leaderboard', [[970, 250], [970, 90], [728, 90]], 'div-gpt-ad-1524246860813-0').addService(googletag.pubads());
    googletag.defineSlot('/309686595/first_break', [728, 90], 'div-gpt-ad-1524246972932-0').addService(googletag.pubads());
    googletag.defineSlot('/309686595/content_bottom', [728, 90], 'div-gpt-ad-1524247046711-0').addService(googletag.pubads());
    googletag.defineSlot('/309686595/footer', [[728, 90], [320, 50], [970, 90]], 'div-gpt-ad-1560969197571-0').addService(googletag.pubads());
    googletag.defineSlot('/309686595/sidebar', [[120, 600], [300, 600], [160, 600], [250, 250], [300, 250]], 'div-gpt-ad-1524248048622-0').addService(googletag.pubads());
    googletag.defineSlot('/309686595/sidebar_house', [[120, 600], [160, 600], [250, 250], [300, 250], [300, 600]], 'div-gpt-ad-1524248095208-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>
<script type="text/javascript" src="//platform-api.sharethis.com/js/sharethis.js#property=58e049bb11d0a70011b391e5&product=inline-share-buttons"></script>
<!-- BEGIN PRIVY WIDGET CODE -->
<script type='text/javascript'> var _d_site = _d_site || '5E2108CEF8D0F073426F8ABF'; </script>
<script src='https://widget.privy.com/assets/widget.js'></script>
<!-- END PRIVY WIDGET CODE -->
<script type="text/javascript" data-cfasync="false">
  (function(W,i,s,e,P,o,p){W['WisePopsObject']=P;W[P]=W[P]||function(){
  (W[P].q=W[P].q||[]).push(arguments)},W[P].l=1*new Date();o=i.createElement(s),
  p=i.getElementsByTagName(s)[0];o.async=1;o.src=e;p.parentNode.insertBefore(o,p)
  })(window,document,'script','//loader.wisepops.com/get-loader.js?v=1&site=hIhxW3M37A','wisepops');
</script>
<head>
  <title>Cuban-American Entrepreneur Ray Yabor 'exemplifies the American Dream' | AL DÍA News</title>  
  <link type="text/css" rel="stylesheet" href="https://aldianews.com/sites/default/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://aldianews.com/sites/default/files/css/css_BP_cb1IXIQidNqUf7vdkGQoeup5dB6-liZqiy7y5Jic.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://aldianews.com/sites/default/files/css/css_ooyXlYEks918iAvyNDjK_96x9aaMrts3RG_iO9SBRmU.css" media="all" />
<style type="text/css" media="all">
<!--/*--><![CDATA[/*><!--*/
#fbcomments,.fb-comments,.fb-comments iframe,.fb-comments span{width:100% !important;}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="https://aldianews.com/sites/default/files/css/css_9iVsGlA5vyI9j4_nIkvpHw9fqoWYgDFFfi1EGf1FkEs.css" media="all" />
<style type="text/css" media="all">
<!--/*--><![CDATA[/*><!--*/
@media screen and (min-width:960px){.responsive-menu-block-wrapper.responsive-menu-block{display:block;}#block-responsive-menu-toggle{display:none;}}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="https://aldianews.com/sites/default/files/css/css_Fgs9ajKnKYWaoh3U_IBQPfPYrEeFCB6j4j2eqRj91HE.css" media="all" />
<style type="text/css" media="all">
<!--/*--><![CDATA[/*><!--*/
#sliding-popup.sliding-popup-bottom,#sliding-popup.sliding-popup-bottom .eu-cookie-withdraw-banner,.eu-cookie-withdraw-tab{background:#055c92;}#sliding-popup.sliding-popup-bottom.eu-cookie-withdraw-wrapper{background:transparent}#sliding-popup .popup-content #popup-text h1,#sliding-popup .popup-content #popup-text h2,#sliding-popup .popup-content #popup-text h3,#sliding-popup .popup-content #popup-text p,.eu-cookie-compliance-secondary-button,.eu-cookie-withdraw-tab{color:#fff !important;}.eu-cookie-withdraw-tab{border-color:#fff;}.eu-cookie-compliance-more-button{color:#fff !important;}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="https://aldianews.com/sites/default/files/css/css_L5A9omJKUi4DnvX0B6GTbFHReA_iIZ52ljv7BlOI1sc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://aldianews.com/sites/all/themes/reader/css/red-style.css?ptrsdv" media="all" />

<!--[if (lt IE 9)&(!IEMobile)]>
<link type="text/css" rel="stylesheet" href="https://aldianews.com/sites/default/files/css/css_BPiP-TJ3upMOvjCncKHAWlBRbzTFOlQNLuV7-ePy-5M.css" media="all" />
<![endif]-->

<!--[if gte IE 9]><!-->
<link type="text/css" rel="stylesheet" href="https://aldianews.com/sites/default/files/css/css_vVMqcfKK4nC8TvqH234hxGb-HAlKTPBJsdAKOI0r4NE.css" media="all" />
<!--<![endif]-->
  <script type="text/javascript" src="https://aldianews.com/sites/default/files/js/js_AjYd6-hmmEYSIWnjq5OhjLx6tHMw7tT5AV9QZTYTRQw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.google_analytics_uacct = "UA-746191-7";
//--><!]]>
</script>
<script type="text/javascript" src="https://aldianews.com/sites/default/files/js/js_pjDHsQXbkxe4jnjVeXL7zsEt7TjqMldkSU726SqgL00.js"></script>
<script type="text/javascript" src="https://aldianews.com/sites/default/files/js/js_xNRocOv7S7JP224n0ZZ2ztWChKItR6xURL8S8otNS6Y.js"></script>
<script type="text/javascript" src="https://aldianews.com/sites/default/files/js/js_jJZKH0vl8oDdSR2ZoOxNVPDcAORJBjCAgu1pbxgBvq4.js"></script>
<script type="text/javascript" src="https://aldianews.com/sites/default/files/js/js_bFLsVxDG-wLab9OxkYEsns8pyaJjlgX5xzHcNTnlACU.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-746191-7", {"cookieDomain":"auto"});ga("set", "anonymizeIp", true);ga("set", "dimension1", "Lee Nentwig");ga("set", "dimension2", "Leaders");ga("set", "dimension5", "Wed, 06\/26\/2019 - 6:25pm");ga("set", "dimension9", "Ray Yabor, leaders, Entrepreneur, New American Award, Immigrant Heritage Month");ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript" src="https://aldianews.com/sites/default/files/js/js_kgpU9wc4jTk4VOvrC1KfCCrhxZufR704m_rk0Mxnyvs.js"></script>
<script type="text/javascript" src="https://aldianews.com/sites/default/files/js/js_diWL3aQY3h6RRBatVIE0RJfaXsBie-hoJ861ArHzvB0.js"></script>
<script type="text/javascript">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</script>
  <!--[if lt IE 9]>
    <script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
  <![endif]-->
  <!--[if IE 8]>
    <link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/reader/css/ie8-fixes.css" />
  <![endif]-->
  <!--[if IE 7]>  
    <link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/reader/css/ie7-fixes.css" />
  <![endif]-->
  <!--[if IE]>  
    <link type="text/css" rel="stylesheet" media="all" href="/sites/all/themes/reader/css/ie-fixes.css" />
  <![endif]-->
  <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.min.css">
<link href="https://fonts.googleapis.com/css?family=Montserrat:400,700" rel="stylesheet">
<script src="https://use.typekit.net/bnn5vhh.js"></script>
<script>try{Typekit.load({ async: true });}catch(e){}</script>
</head>
<body class="html not-front not-logged-in page-node page-node- page-node-55921 node-type-article i18n-en context-articles">
  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
  <div class="region region-page-top" id="region-page-top"><div class="region-inner region-page-top-inner"> <noscript aria-hidden="true"><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NV5RTNW" height="0" width="0" style="display:none;visibility:hidden" title="Google Tag Manager">Google Tag Manager</iframe></noscript></div></div>  <div class="page clearfix" id="page"> <header id="section-header" class="section section-header"><div id="zone-branding-wrapper" class="zone-wrapper zone-branding-wrapper clearfix"><div id="zone-branding" class="zone zone-branding clearfix container-16"><div class="grid-4 region region-branding" id="region-branding"><div class="region-inner region-branding-inner"></div></div><div class="grid-12 region region-menu" id="region-menu"><div class="region-inner region-menu-inner"><div class="region region-blockgroup-logo-and-breadcrumb blockgroup" id="region-blockgroup-logo-and-breadcrumb"><div class="region-inner region-blockgroup-logo-and-breadcrumb-inner"><div class="block block-blockify block-blockify-logo block-blockify-blockify-logo odd block-without-title" id="block-blockify-blockify-logo"><div class="block-inner clearfix"><div class="content clearfix"> <a href="/" id="logo" rel="home" title="Return to the AL DÍA News home page"><img src="https://aldianews.com/sites/default/files/logo2b_0.png" alt="AL DÍA News logo" /></a></div></div></div><div class="block block-views block-taxonomy-breadcrumb-block-1 block-views-taxonomy-breadcrumb-block-1 even block-without-title" id="block-views-taxonomy-breadcrumb-block-1"><div class="block-inner clearfix"><div class="content clearfix"><div class="view view-taxonomy-breadcrumb view-id-taxonomy_breadcrumb view-display-id-block_1 view-dom-id-5349bd2f11af608c484d30683079e6c2"><div class="view-content"><div class="views-row views-row-1 views-row-odd views-row-first views-row-last"><div class="views-field views-field-field-topics"><div class="field-content"><div class="taxonomy-breadcrumb"><a href="/topics/leaders/13579">Leaders</a></div></div></div></div></div></div></div></div></div></div></div><div class="region region-blockgroup-header-menu-group blockgroup" id="region-blockgroup-header-menu-group"><div class="region-inner region-blockgroup-header-menu-group-inner"><div class="block block-locale block-language block-locale-language odd block-without-title" id="block-locale-language"><div class="block-inner clearfix"><div class="content clearfix"><ul class="language-switcher-locale-url"><li class="en first active"><a href="/articles/leaders/cuban-american-entrepreneur-ray-yabor-exemplifies-american-dream/55921" class="language-link active" xml:lang="en" title="Cuban-American Entrepreneur Ray Yabor &#039;exemplifies the American Dream&#039;">ENG</a></li><li class="es last"><a href="/es/articles/leaders/el-emprendedor-cubano-estadounidense-ray-yabor-ejemplifica-el-sueno-americano/55922" class="language-link" xml:lang="es" title="El emprendedor cubano-estadounidense Ray Yabor &#039;ejemplifica el Sueño Americano&#039;">ESP</a></li></ul></div></div></div><div class="block block-nice-menus block-1 block-nice-menus-1 even block-without-title" id="block-nice-menus-1"><div class="block-inner clearfix"><div class="content clearfix"><ul class="nice-menu nice-menu-down nice-menu-main-menu" id="nice-menu-1"><li class="menu-2836 menuparent menu-path-nolink first odd "><span title="" class="nolink">S</span><ul><li class="menu-2761 menu-path-view first odd last menu-views"><div class="view view-search-block view-id-search_block view-display-id-page_1 view-dom-id-7fbe82ec8b47a66b09e2e5089bfc96c9"><div class="view-filters"><form action="/search-results/" method="get" id="views-exposed-form-search-block-page-1" accept-charset="UTF-8"><div><div class="views-exposed-form"><div class="views-exposed-widgets clearfix"><div id="edit-combine-wrapper" class="views-exposed-widget views-widget-filter-combine"><div class="views-widget"><div class="form-item form-type-textfield form-item-combine"> <input type="text" id="edit-combine" name="combine" value="" size="30" maxlength="128" class="form-text" /></div></div></div><div class="views-exposed-widget views-submit-button"> <input type="submit" id="edit-submit-search-block" name="" value="Search" class="form-submit" /></div></div></div></div></form></div></div></li></ul></li><li class="menu-218 menuparent menu-path-nolink even "><span title="" class="nolink">☰ SECTIONS</span><ul><li class="menu-5303 menu-path-videos first odd "><a href="/videos" title="">Videos</a></li><li class="menu-6792 menu-path-taxonomy-term-13258 even "><a href="/tags/podcast/13258" title="">Podcasts</a></li><li class="menu-5302 menu-path-events odd "><a href="/events" title="">AL DíA Live</a></li><li class="menu-3914 menu-path-taxonomy-term-2 even "><a href="/topics/politics/2" title="Politics">Politics</a></li><li class="menu-3924 menu-path-taxonomy-term-3 odd "><a href="/topics/culture/3" title="Culture">Culture</a></li><li class="menu-5257 menu-path-taxonomy-term-13579 even "><a href="/topics/leaders/13579" title="">Leaders</a></li><li class="menu-3917 menu-path-taxonomy-term-11 odd "><a href="/topics/politics/education/11" title="Education">Education</a></li><li class="menu-5258 menu-path-taxonomy-term-218 even "><a href="/topics/culture/health/218" title="">Health</a></li><li class="menu-6647 menu-path-cuentame-tellme odd "><a href="/cuentame-tellme" title="Real Life Stories of Latinos in the US">Cuéntame / Tell Me</a></li><li class="menu-6652 menu-path-aldianewscom-women-summit even "><a href="https://aldianews.com/women-summit" title="">Women</a></li><li class="menu-5296 menu-path-american-immigrants odd last"><a href="/american-immigrants" title="American Immigrant project Highlights Latino immigrant​s ​who ​are​ making ​Philadelphia a better place for all.">New Americans</a></li></ul></li><li class="menu-838 menuparent menu-path-nolink odd "><span title="" class="nolink">MORE</span><ul><li class="menu-6642 menu-path-aldiajobs first odd "><a href="/aldiajobs" title="">AL DIA Jobs</a></li><li class="menu-5297 menu-path-node-34546 even "><a href="/pages/more/about-us/34546" title="">Advertise</a></li><li class="menu-2741 menu-path-node-34546 odd "><a href="/pages/more/about-us/34546">About us</a></li><li class="menu-5298 menu-path-node-34560 even "><a href="/pages/contact-us/34560" title="">Contact us</a></li><li class="menu-5299 menu-path-node-34548 odd "><a href="/careers" title="">Careers at AL DÍA</a></li><li class="menu-5300 menu-path-tips even "><a href="/tips" title="">Share a News Tip</a></li><li class="menu-6646 menu-path-aldianewscom-authors-hernc3a1n-guaracao-394 odd "><a href="https://aldianews.com/authors/hern%C3%A1n-guaracao/394" title="">Editor In Chief&#039;s Page</a></li><li class="menu-7181 menu-path-print-edition-pricing-page even last"><a href="/print-edition-pricing-page" title="">Subscriptions</a></li></ul></li><li class="menu-2307 menuparent menu-path-nolink even last"><span title="" class="nolink">CONNECT</span><ul><li class="menu-2749 menu-path-sfacebookcom-aldianews first odd "><a href="https://www.facebook.com/ALDIANews" class="menu_icon menu-2749">Facebook</a></li><li class="menu-2753 menu-path-instagramcom-aldianews even "><a href="https://instagram.com/aldianews" class="menu_icon menu-2753">Instagram</a></li><li class="menu-2750 menu-path-stwittercom-aldianews odd "><a href="https://twitter.com/aldianews" class="menu_icon menu-2750">Twitter</a></li><li class="menu-2755 menu-path-syoutubecom-user-pontealdiatv even last"><a href="https://www.youtube.com/user/pontealdiatv" class="menu_icon menu-2755">Youtube</a></li></ul></li></ul></div></div></div><div class="block block-responsive-menu block-horizontal-menu block-responsive-menu-horizontal-menu odd block-without-title" id="block-responsive-menu-horizontal-menu"><div class="block-inner clearfix"><div class="content clearfix"> <nav class="responsive-menu-block-wrapper responsive-menu-block menu-name-main-menu"><ul id="horizontal-menu" class="horizontal-menu"><li class="first expanded menu-mlid-2836"><span title="" class="nolink">S</span><ul class="sub-nav menu-tree-mlid-2836"><li class="first last leaf menu-mlid-2761"><a href="/%3Cview%3E" title="">SEARCH</a></li></ul></li><li class="expanded menu-mlid-218"><span title="" class="nolink">☰ SECTIONS</span><ul class="sub-nav menu-tree-mlid-218"><li class="first leaf menu-mlid-5303"><a href="/videos" title="">Videos</a></li><li class="leaf menu-mlid-6792"><a href="/tags/podcast/13258" title="">Podcasts</a></li><li class="leaf menu-mlid-5302"><a href="/events" title="">AL DíA Live</a></li><li class="leaf menu-mlid-3914"><a href="/topics/politics/2" title="Politics">Politics</a></li><li class="leaf menu-mlid-3924"><a href="/topics/culture/3" title="Culture">Culture</a></li><li class="leaf menu-mlid-5257"><a href="/topics/leaders/13579" title="">Leaders</a></li><li class="leaf menu-mlid-3917"><a href="/topics/politics/education/11" title="Education">Education</a></li><li class="leaf menu-mlid-5258"><a href="/topics/culture/health/218" title="">Health</a></li><li class="leaf menu-mlid-6647"><a href="/cuentame-tellme" title="Real Life Stories of Latinos in the US">Cuéntame / Tell Me</a></li><li class="leaf menu-mlid-6652"><a href="https://aldianews.com/women-summit" title="">Women</a></li><li class="last leaf menu-mlid-5296"><a href="/american-immigrants" title="American Immigrant project Highlights Latino immigrant​s ​who ​are​ making ​Philadelphia a better place for all.">New Americans</a></li></ul></li><li class="expanded menu-mlid-838"><span title="" class="nolink">MORE</span><ul class="sub-nav menu-tree-mlid-838"><li class="first leaf menu-mlid-6642"><a href="/aldiajobs" title="">AL DIA Jobs</a></li><li class="leaf menu-mlid-5297"><a href="/pages/more/about-us/34546" title="">Advertise</a></li><li class="leaf menu-mlid-2741"><a href="/pages/more/about-us/34546">About us</a></li><li class="leaf menu-mlid-5298"><a href="/pages/contact-us/34560" title="">Contact us</a></li><li class="leaf menu-mlid-5299"><a href="/careers" title="">Careers at AL DÍA</a></li><li class="leaf menu-mlid-5300"><a href="/tips" title="">Share a News Tip</a></li><li class="leaf menu-mlid-6646"><a href="https://aldianews.com/authors/hern%C3%A1n-guaracao/394" title="">Editor In Chief&#039;s Page</a></li><li class="last leaf menu-mlid-7181"><a href="/print-edition-pricing-page" title="">Subscriptions</a></li></ul></li><li class="last expanded menu-mlid-2307"><span title="" class="nolink">CONNECT</span><ul class="sub-nav menu-tree-mlid-2307"><li class="first leaf menu-mlid-2749"><a href="https://www.facebook.com/ALDIANews" class="menu_icon menu-2749">Facebook</a></li><li class="leaf menu-mlid-2753"><a href="https://instagram.com/aldianews" class="menu_icon menu-2753">Instagram</a></li><li class="leaf menu-mlid-2750"><a href="https://twitter.com/aldianews" class="menu_icon menu-2750">Twitter</a></li><li class="last leaf menu-mlid-2755"><a href="https://www.youtube.com/user/pontealdiatv" class="menu_icon menu-2755">Youtube</a></li></ul></li></ul></nav></div></div></div><div class="block block-responsive-menu block-toggle block-responsive-menu-toggle even block-without-title" id="block-responsive-menu-toggle"><div class="block-inner clearfix"><div class="content clearfix"> <a id="toggle-icon" class="toggle responsive-menu-toggle-icon" title="Menu" href="#off-canvas"> <span class="icon"></span><span class="label">Menu</span></a></div></div></div></div></div></div></div></div></div><div id="zone-header-wrapper" class="zone-wrapper zone-header-wrapper clearfix"><div id="zone-header" class="zone zone-header clearfix container-16"><div class="grid-16 region region-header-first" id="region-header-first"><div class="region-inner region-header-first-inner"><div class="block block-views block-taxonomy-breadcrumb-block-2 block-views-taxonomy-breadcrumb-block-2 odd block-without-title" id="block-views-taxonomy-breadcrumb-block-2"><div class="block-inner clearfix"><div class="content clearfix"><div class="view view-taxonomy-breadcrumb view-id-taxonomy_breadcrumb view-display-id-block_2 view-dom-id-854b58a32c88529b42fa602c44da8651"><div class="view-content"><div class="views-row views-row-1 views-row-odd views-row-first views-row-last"><div class="views-field views-field-field-topics"><div class="field-content"><div class="taxonomy-breadcrumb-mobile"><a href="/topics/leaders/13579">Leaders</a></div></div></div></div></div></div></div></div></div><section class="block block-block block-63 block-block-63 even" id="block-block-63"><div class="block-inner clearfix"><h2 class="block-title"><span>Advertisement</span></h2><div class="content clearfix"><div id="div-gpt-ad-1524246860813-0">
<script>
<!--//--><![CDATA[// ><!--
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1524246860813-0'); });
//--><!]]>
</script></div></div></div></section></div></div></div></div></header> <section id="section-content" class="section section-content"><div id="zone-content" class="zone zone-content clearfix container-16"><div class="grid-12 region region-content" id="region-content"><div class="region-inner region-content-inner"> <a id="main-content"></a><h1 class="title" id="page-title">Cuban-American Entrepreneur Ray Yabor &#039;exemplifies the American Dream&#039;</h1><div class="block block-views block-64cbf824c73ec01dd4a287a14559fc2b block-views-64cbf824c73ec01dd4a287a14559fc2b odd block-without-title" id="block-views-64cbf824c73ec01dd4a287a14559fc2b"><div class="block-inner clearfix"><div class="content clearfix"><div class="view view-node-parts-for-node-override-articles view-id-node_parts_for_node_override_articles view-display-id-block_30 node-related-terms view-dom-id-a57002843f917992cdd8efcd22938aef"><div class="view-content"><div class="views-row views-row-1 views-row-odd views-row-first views-row-last"><div class="views-field views-field-field-soundcloud-url"><div class="field-content"></div></div></div></div></div></div></div></div><div class="block block-views block-e27a93476888f27b59cfebfd4917afaf block-views-e27a93476888f27b59cfebfd4917afaf even block-without-title" id="block-views-e27a93476888f27b59cfebfd4917afaf"><div class="block-inner clearfix"><div class="content clearfix"><div class="view view-node-parts-for-node-override-articles view-id-node_parts_for_node_override_articles view-display-id-block_1 node-related-terms view-dom-id-3beba9cfa9a3367c5a2d98d93cb3d6c7"><div class="view-content"><div class="views-row views-row-1 views-row-odd views-row-first views-row-last"><div class="views-field views-field-nothing"> <span class="field-content"><img src="https://aldianews.com/sites/default/files/styles/article_image/public/articles/pg-14-1131.jpg?itok=CMaDm1Nx" width="1131" height="645" alt="Cuban-American entrepreneur Ray Yabor will be honored by AL DÍA for his contributions to the immigrant community of Philadelphia at The New American reception on Saturday, June 29. Photo: AL DÍA News" title="Cuban-American entrepreneur Ray Yabor will be honored by AL DÍA for his contributions to the immigrant community of Philadelphia at The New American reception on Saturday, June 29. Photo: AL DÍA News" /><div id="header-image-caption"><p>Cuban-American entrepreneur Ray Yabor will be honored by AL DÍA for his contributions to the immigrant community of Philadelphia at The New American reception on Saturday, June 29. Photo: AL DÍA News</p></div></span></div></div></div></div></div></div></div><div class="block block-views block-language-switcher-block-block-2 block-views-language-switcher-block-block-2 odd block-without-title" id="block-views-language-switcher-block-block-2"><div class="block-inner clearfix"><div class="content clearfix"><div class="view view-language-switcher-block view-id-language_switcher_block view-display-id-block_2 view-dom-id-414c7aafd60c004f53493d714b1226d2"><div class="view-content"><div class="views-row views-row-1 views-row-odd views-row-first views-row-last"><div class="views-field views-field-tnid"> <span class="field-content"><a href="https://aldianews.com/es/node/55921"><div class="language-switcher-div"><div class="language-switcher-views-esp">Lea en Español</div></div></a></span></div></div></div></div></div></div></div><div class="block block-views block-language-switcher-block-block-4 block-views-language-switcher-block-block-4 even block-without-title" id="block-views-language-switcher-block-block-4"><div class="block-inner clearfix"><div class="content clearfix"><div class="view view-language-switcher-block view-id-language_switcher_block view-display-id-block_4 view-dom-id-9672c1f68f7afc4be5943d157456c449"><div class="view-content"><div class="views-row views-row-1 views-row-odd views-row-first views-row-last"><div class="views-field views-field-tnid"> <span class="field-content"><a href="https://aldianews.com/es/node/55921"><div class="language-switcher-views-esp">Lea en Español</div></a></span></div></div></div></div></div></div></div><div class="block block-views block-e26715d7f5c4f271f31155b68f5bd0b3 block-views-e26715d7f5c4f271f31155b68f5bd0b3 odd block-without-title" id="block-views-e26715d7f5c4f271f31155b68f5bd0b3"><div class="block-inner clearfix"><div class="content clearfix"><div class="view view-node-parts-for-node-override-articles view-id-node_parts_for_node_override_articles view-display-id-block_29 node-related-terms view-dom-id-79cbb461e55e86d1382e313df61191fb"><div class="view-content"><div class="views-row views-row-1 views-row-odd views-row-first views-row-last"></div></div></div></div></div></div><div class="block block-views block-2042cc38207a84de535c48bd808d3e2a block-views-2042cc38207a84de535c48bd808d3e2a even block-without-title" id="block-views-2042cc38207a84de535c48bd808d3e2a"><div class="block-inner clearfix"><div class="content clearfix"><div class="view view-node-parts-for-node-override-articles view-id-node_parts_for_node_override_articles view-display-id-block_2 node-related-terms view-dom-id-4b645ac9f8c3b4ef2a414ae9d4fe5871"><div class="view-content"><div class="views-row views-row-1 views-row-odd views-row-first views-row-last"><div class="views-field views-field-nothing"> <span class="field-content"><div id="page-title">Cuban-American Entrepreneur Ray Yabor &#039;exemplifies the American Dream&#039;</div><div id="node-summary"><p>Ray Yabor built one of the most successful Latino-owned businesses in Philadelphia and made lasting&nbsp;impact through his work with the Greater Philadelphia Hispanic Chamber of Commerce.</p></div><div class="div-border-bottom"></div></span></div></div></div></div></div></div></div><div class="block block-block block-19 block-block-19 odd block-without-title" id="block-block-19"><div class="block-inner clearfix"><div class="content clearfix"><div class="sharethis-inline-share-buttons"></div></div></div></div><div class="block block-system block-main block-system-main even block-without-title" id="block-system-main"><div class="block-inner clearfix"><div class="content clearfix"> <article id="node-55921" class="node node-article node-promoted node-sticky en clearfix" class="node node-article node-promoted node-sticky en node-published author-leen odd clearfix" id="node-article-55921"> <header> </header><div class="header-info"><div class="article-author"><span>by </span> <span class="author-name">leen</span></div><div class="article-create-date"><i class="fa fa-clock-o themecolor-text"></i> &nbsp;06/26/2019 - 18:25</div><div class="article-category"><span>in </span></div></div><div class="image-region"><div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><img src="https://aldianews.com/sites/default/files/styles/article_image/public/articles/pg-14-1131.jpg?itok=CMaDm1Nx" width="1131" height="645" alt="Cuban-American entrepreneur Ray Yabor will be honored by AL DÍA for his contributions to the immigrant community of Philadelphia at The New American reception on Saturday, June 29. Photo: AL DÍA News" title="Cuban-American entrepreneur Ray Yabor will be honored by AL DÍA for his contributions to the immigrant community of Philadelphia at The New American reception on Saturday, June 29. Photo: AL DÍA News" /></div></div></div></div><div class="content" class="content clearfix"><div class="content-inner"></div></div><div id="block-views-author-block" class="block-author-block block-views-author-block"><div class="block-inner clearfix"><div class="content"><div class="view view-author view-id-author view-display-id-block view-dom-id-cf675cc98085c2589fe4508c4c0ade2d"><div class="view-content"><div class="views-row views-row-1 views-row-odd views-row-first views-row-last"><div class="views-field views-field-picture"><div class="field-content"></div></div><div class="views-field views-field-field-full-name"><div class="field-content">Lee Nentwig</div></div><div class="views-field views-field-field-about"><div class="field-content"></div></div><div class="views-field views-field-field-personal-blog"><div class="field-content"></div></div></div></div></div></div></div></div> <footer> </footer> </article></div></div></div><div class="region region-blockgroup-sticky-nav-group blockgroup" id="region-blockgroup-sticky-nav-group"><div class="region-inner region-blockgroup-sticky-nav-group-inner"><div class="block block-views block-2960f5125fe192cc37a61e8b784a2515 block-views-2960f5125fe192cc37a61e8b784a2515 odd block-without-title" id="block-views-2960f5125fe192cc37a61e8b784a2515"><div class="block-inner clearfix"><div class="content clearfix"><div class="view view-sticky-navigation-views-block view-id-sticky_navigation_views_block view-display-id-block_2 view-dom-id-6bb2ab8d78d1b98049dde3c2cadd0044"><div class="view-content"><div class="views-row views-row-1 views-row-odd views-row-first views-row-last"><div class="views-field views-field-nothing-1"> <span class="field-content"><div id="stickynavviewsblock2"><span class="logoinblock2"><a href="/"><img src="https://aldianews.com/sites/default/files/images/logo2b.png"></a></span><span class="titlecontainer"><span class="titleinsticky2">Cuban-American Entrepreneur Ray Yabor &#039;...</span></span></div></span></div></div></div></div></div></div></div><div class="block block-block block-19 block-block-19--2 even block-without-title" id="block-block-19--2"><div class="block-inner clearfix"><div class="content clearfix"><div class="sharethis-inline-share-buttons"></div></div></div></div></div></div><div class="block block-views block-b027e00ff21656aa666b2e04beda6469 block-views-b027e00ff21656aa666b2e04beda6469 odd block-without-title" id="block-views-b027e00ff21656aa666b2e04beda6469"><div class="block-inner clearfix"><div class="content clearfix"><div class="view view-node-parts-for-node-override-articles view-id-node_parts_for_node_override_articles view-display-id-block_25 node-related-terms view-dom-id-5af9dd806338db5850cd1586214af3d6"><div class="view-content"><div class="views-row views-row-1 views-row-odd views-row-first views-row-last"><div class="views-field views-field-field-image-1"><div class="field-content"><div id="hidden-node-image"><a href="/articles/leaders/cuban-american-entrepreneur-ray-yabor-exemplifies-american-dream/55921" class="active"><img src="https://aldianews.com/sites/default/files/styles/article_image/public/articles/pg-14-1131.jpg?itok=CMaDm1Nx" width="1131" height="645" alt="Cuban-American entrepreneur Ray Yabor will be honored by AL DÍA for his contributions to the immigrant community of Philadelphia at The New American reception on Saturday, June 29. Photo: AL DÍA News" title="Cuban-American entrepreneur Ray Yabor will be honored by AL DÍA for his contributions to the immigrant community of Philadelphia at The New American reception on Saturday, June 29. Photo: AL DÍA News" /></a></div></div></div><div class="views-field views-field-nothing-1"> <span class="field-content"><div class="full-node-content-container"><div class="left-side-element"><a href="/authors/lee-nentwig/17392"><img src="https://aldianews.com/sites/default/files/styles/220x220scale_and_crop/public/field/authorimage/biophotobw.png?itok=jqKxHDbg" width="220" height="220" alt="" /></a><br><div class="node-author-name-leftside">By <a href="/authors/lee-nentwig/17392">Lee Nentwig</a></div><div class="small-date">June 26, 2019</div></div><div class="right-side-element"><div class="node-body"><p>Ray Yabor arrived in the United States from Cuba when he was only seven years old. To this day, memories of what that experience meant to him at such a young age elude him. </p><p>“It’s hard for me to go back on it, except the first words I learned were ‘I don’t speak English,” he recounted with laughter in a recent conversation with AL DÍA.</p><p>“As a kid you want to play ball, go to school, yell and scream,” Yabor explained. “You don’t realize that you have all of these opportunities here.”</p><p>0But Yabor would grow up to make the very best of the opportunities he was provided by this country. While in school at Villanova University, he began delivering building and janitorial supplies to local businesses out of his own car. </p><p>Three years later, Yabor was running a multi-million dollar enterprise called 503 Corporation. He purchased a 10,000 square foot facility to house the operation in the Frankford neighborhood of Philadelphia. </p><p>After establishing himself as an entrepreneur, Yabor took on a leadership role at the Greater Philadelphia Hispanic Chamber of Commerce (GPHCC). He saw it as a way to help open pathways for more Latino entrepreneurs and business owners in the city to thrive. </p><p>“When I joined, the Chamber was falling apart and very disorganized,” Yabor told AL DÍA.</p><p>Together with the six other board members at the time, Yabor helped the Chamber pay off debts that it owed. He appointed new leadership and set the GPHCC on track to become what it is today: one of the most vibrant business networks in Philadelphia. </p><p>As the Latino business community of the city continues to expand each year, the impact of Yabor’s contributions to the GPHCC endure.</p><p>“Ray exemplifies the American Dream,” GPHCC President &amp; CEO Jennifer Rodriguez told AL DÍA. </p><p>“Not only has he been a successful entrepreneur,” she continued, “but also a civic leader, dedicating many years to the development and growth of the Greater Philadelphia Hispanic Chamber of Commerce.”</p><p>Yabor recognizes potential in all immigrants to make a similar impact in communities across the country.</p><p>He characterizes immigrants as “people who are reaching out, not for a handout, but for a start,” and believes that immigrants should be perceived as an investment, not a burden. In each new immigrant, Yabor sees a future taxpayer, citizen, and creator.</p><p>Closing the country’s borders is contradictory to the image of itself that the United States projects to the outside world as a land of freedom and opportunity, according to Yabor. </p><p>“We try to proclaim that all through the world, yet we blame the people who we recruit by doing it,” he said. “Don’t preach and then blame the people for accepting the words that just came right out of your mouth.”</p><p>Despite this sentiment, Yabor remains proud of both his Cuban and American identity. The now retired entrepreneur reflects back with profound gratitude for the opportunities he has had in his life, opportunities only possible in a country like the United States of America.</p></div><div class="space-between-divs"></div><div class="also-listed-in-header">TAGS</div><div class="related-topics-item"><a href="/tags/ray-yabor/18291">Ray Yabor</a></div><div class="related-topics-item"><a href="/tags/leaders/16952">leaders</a></div><div class="related-topics-item"><a href="/tags/entrepreneur/1418">Entrepreneur</a></div><div class="related-topics-item"><a href="/tags/new-american-award/18292">New American Award</a></div><div class="related-topics-item"><a href="/tags/immigrant-heritage-month/9975">Immigrant Heritage Month</a></div></div></div></span></div></div></div></div></div></div></div><section class="block block-facebook-comments block-facebook-comments block-facebook-comments-facebook-comments even" id="block-facebook-comments-facebook-comments"><div class="block-inner clearfix"><h2 class="block-title"><span>Please tell us what you think about this story</span></h2><div class="content clearfix"><div id="fb-root"></div>
<script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) {return;}
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_GB/all.js#xfbml=1";
fjs.parentNode.insertBefore(js, fjs);
}(document, "script", "facebook-jssdk"));</script>
<div class="fb-comments fb-comments-fluid" data-href="https://aldianews.com/articles/leaders/cuban-american-entrepreneur-ray-yabor-exemplifies-american-dream/55921" data-num-posts="20" data-width="620" data-colorscheme="light"></div></div></div></section><section class="block block-views block-dee88b93bff5b49fba8d21eda84afd59 block-views-dee88b93bff5b49fba8d21eda84afd59 odd" id="block-views-dee88b93bff5b49fba8d21eda84afd59"><div class="block-inner clearfix"><h2 class="block-title"><span>More in Leaders</span></h2><div class="content clearfix"><div class="view view-nodes-related-to-current-node-clone-of-taxonomy-page-view view-id-nodes_related_to_current_node_clone_of_taxonomy_page_view view-display-id-block_19 taxonomy-views-page-display view-dom-id-03e845dd9208e2a576ebf93aeae44a08"><div class="view-content"><div class="views-row views-row-1 views-row-odd views-row-first"><div class="views-field views-field-field-image"><div class="field-content"><a href="/articles/leaders/purpose-and-values-business/55917"><img src="https://aldianews.com/sites/default/files/styles/attached_article_photo__x3_/public/articles/pg-39-1131_0.jpg?itok=sdDUw6na" alt="Richard Branson Photo: depositphotos.com
" title="Richard Branson Photo: depositphotos.com
" /></a></div></div><div class="views-field views-field-title"> <span class="field-content"><a href="/articles/leaders/purpose-and-values-business/55917">Purpose and values in business</a></span></div></div><div class="views-row views-row-2 views-row-even"><div class="views-field views-field-field-image"><div class="field-content"><a href="/articles/leaders/building-immigrant-leaders-philadelphia/55891"><img src="https://aldianews.com/sites/default/files/styles/attached_article_photo__x3_/public/articles/img-7853.jpg?itok=NQfYpvWA" alt="Photo: Welcoming Center for New Pennsylvanians. " title="Photo: Welcoming Center for New Pennsylvanians. " /></a></div></div><div class="views-field views-field-title"> <span class="field-content"><a href="/articles/leaders/building-immigrant-leaders-philadelphia/55891">Building immigrant leaders in Philadelphia</a></span></div></div><div class="views-row views-row-3 views-row-odd"><div class="views-field views-field-field-image"><div class="field-content"><a href="/articles/leaders/helping-incarcerated-individuals-reenter-society/55914"><img src="https://aldianews.com/sites/default/files/styles/attached_article_photo__x3_/public/articles/img-7190.jpg?itok=acRN3NIy" alt="The Honorable Judge Felipe Restrepo moderates panel with Jacqueline Romero, Ross Thompson, et al. Photo: Jensen Toussaint" title="The Honorable Judge Felipe Restrepo moderates panel with Jacqueline Romero, Ross Thompson, et al. Photo: Jensen Toussaint" /></a></div></div><div class="views-field views-field-title"> <span class="field-content"><a href="/articles/leaders/helping-incarcerated-individuals-reenter-society/55914">Helping incarcerated individuals reenter society</a></span></div></div><div class="views-row views-row-4 views-row-even views-row-last"><div class="views-field views-field-field-image"><div class="field-content"><a href="/articles/leaders/naleo-annual-conference-kicks-miami/55887"><img src="https://aldianews.com/sites/default/files/styles/attached_article_photo__x3_/public/articles/rsz_naleo_sn23_0.jpg?itok=o482LJXq" alt="Attendees during the 36th Annual NALEO Conference. Photo: Samuel Navarro" title="Attendees during the 36th Annual NALEO Conference. Photo: Samuel Navarro" /></a></div></div><div class="views-field views-field-title"> <span class="field-content"><a href="/articles/leaders/naleo-annual-conference-kicks-miami/55887">NALEO Annual Conference kicks off in Miami</a></span></div></div></div></div></div></div></section></div></div><aside class="grid-4 region region-sidebar-second" id="region-sidebar-second"><div class="region-inner region-sidebar-second-inner"> <section class="block block-views block-list-articles-block-3 block-views-list-articles-block-3 odd" id="block-views-list-articles-block-3"><div class="block-inner clearfix"><h2 class="block-title"><span>Related Stories</span></h2><div class="content clearfix"><div class="view view-list-articles view-id-list_articles view-display-id-block_3 block-most-view-articles view-dom-id-c4b7ae7f6a7a73948d1b71c915006360"><div class="view-empty"><div class="view view-list-articles view-id-list_articles view-display-id-block_7 block-most-view-articles view-dom-id-c8a8a67fbc1a6dfec6f818b0d365835d"><div class="view-content"><div class="views-row views-row-1 views-row-odd views-row-first"><div class="views-field views-field-field-image"><div class="field-content"><a href="/articles/politics/opinion/demokratia/55925"><img src="https://aldianews.com/sites/default/files/styles/list-articles/public/articles/pg-03-1131_5.jpg?itok=LKo5vois" width="280" height="220" alt="Demokratia: a woman crowning old man Demos, the people, a detail from an Athenian law sculpted in marble, 336 BCE.
" title="Demokratia: a woman crowning old man Demos, the people, a detail from an Athenian law sculpted in marble, 336 BCE.
" /></a></div></div><div class="views-field views-field-nothing"> <span class="field-content"><div class="latest-news-block"><a href="/articles/politics/opinion/demokratia/55925"><span class="latest-news-block-title">DEMOKRATIA</span></a></div></span></div></div><div class="views-row views-row-2 views-row-even"><div class="views-field views-field-field-image"><div class="field-content"><a href="/articles/education/decoding-culture-tech-philly-educators-rewiring-way-youth-engage-technology/55795"><img src="https://aldianews.com/sites/default/files/styles/list-articles/public/articles/techfeatureimage.jpg?itok=tFOSU4ro" width="280" height="220" alt="By integrating diverse learning styles and fostering collaboration, the ExCITe Center catalyzes community around tech education. Photo: ExCITe Center at Drexel University" title="By integrating diverse learning styles and fostering collaboration, the ExCITe Center catalyzes community around tech education. Photo: ExCITe Center at Drexel University" /></a></div></div><div class="views-field views-field-nothing"> <span class="field-content"><div class="latest-news-block"><a href="/articles/education/decoding-culture-tech-philly-educators-rewiring-way-youth-engage-technology/55795"><span class="latest-news-block-title">Decoding the culture of tech: Philly educators rewiring the way youth engage technology</span></a></div></span></div></div><div class="views-row views-row-3 views-row-odd"><div class="views-field views-field-field-image"><div class="field-content"><a href="/articles/culture/immigration-stories/51-immigrants-become-new-us-citizens/55790"><img src="https://aldianews.com/sites/default/files/styles/list-articles/public/articles/final_photo_.jpg?itok=phSoxmsW" width="280" height="220" alt="New citizens celebrate at the naturalization ceremony held as part of Immigrant Heritage Month at the Free Library of Philadelphia on June 11. Photo: Rivka Pruss / AL DÍA News" title="New citizens celebrate at the naturalization ceremony held as part of Immigrant Heritage Month at the Free Library of Philadelphia on June 11. Photo: Rivka Pruss / AL DÍA News" /></a></div></div><div class="views-field views-field-nothing"> <span class="field-content"><div class="latest-news-block"><a href="/articles/culture/immigration-stories/51-immigrants-become-new-us-citizens/55790"><span class="latest-news-block-title">51 immigrants become new U.S. citizens</span></a></div></span></div></div><div class="views-row views-row-4 views-row-even"><div class="views-field views-field-field-image"><div class="field-content"><a href="/articles/culture/immigration-stories/philadelphians-celebrate-immigrants-love-park/55739"><img src="https://aldianews.com/sites/default/files/styles/list-articles/public/articles/d8o6qgpwkae67pu.jpg?itok=HsIsdNmD" width="280" height="220" alt="Participants in the Celebrate Immigrants event placed the flags of various countries on the art installation &quot;I Love Philly&quot; on June 4. Photo: Jensen Toussaint / AL DÍA News" title="Participants in the Celebrate Immigrants event placed the flags of various countries on the art installation &quot;I Love Philly&quot; on June 4. Photo: Jensen Toussaint / AL DÍA News" /></a></div></div><div class="views-field views-field-nothing"> <span class="field-content"><div class="latest-news-block"><a href="/articles/culture/immigration-stories/philadelphians-celebrate-immigrants-love-park/55739"><span class="latest-news-block-title">Philadelphians celebrate immigrants in Love Park</span></a></div></span></div></div><div class="views-row views-row-5 views-row-odd views-row-last"><div class="views-field views-field-field-image"><div class="field-content"><a href="/articles/cultura/immigration-stories/dont-miss-these-national-immigrant-heritage-month-events"><img src="https://aldianews.com/sites/default/files/styles/list-articles/public/articles/img_9574_1.jpg?itok=BLGfZjFQ" width="280" height="220" alt="A participant at the Celebrate Immigrants event placed the flag of the United States with the phrase &quot;You are Welcome&quot; with flags from other countries on the art installation &quot;I Love Philly&quot; on June 4. 
Photo: Michelle Myers / AL DÍA News
" title="A participant at the Celebrate Immigrants event placed the flag of the United States with the phrase &quot;You are Welcome&quot; with flags from other countries on the art installation &quot;I Love Philly&quot; on June 4. 
Photo: Michelle Myers / AL DÍA News
" /></a></div></div><div class="views-field views-field-nothing"> <span class="field-content"><div class="latest-news-block"><a href="/articles/cultura/immigration-stories/dont-miss-these-national-immigrant-heritage-month-events"><span class="latest-news-block-title">Don’t miss these National Immigrant Heritage Month events in Philadelphia </span></a></div></span></div></div></div></div></div><div class="view-footer"><div class="view view-list-articles view-id-list_articles view-display-id-block_6 block-most-view-articles view-dom-id-011eae3b002805fcf94cdeab1ca6d744"></div></div></div></div></div></section><section class="block block-block block-67 block-block-67 even" id="block-block-67"><div class="block-inner clearfix"><h2 class="block-title"><span>Advertisement</span></h2><div class="content clearfix"><div id="div-gpt-ad-1524248048622-0">
<script>
<!--//--><![CDATA[// ><!--
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1524248048622-0'); });
//--><!]]>
</script></div></div></div></section><section class="block block-simpleads block-ad-groups-14341 block-simpleads-ad-groups-14341 odd" id="block-simpleads-ad-groups-14341"><div class="block-inner clearfix"><h2 class="block-title"><span>Advertisement</span></h2><div class="content clearfix"><div class="header"><div class="ad-link"></div></div><div class="adslist">
<script type="text/javascript">
_simpelads_load('.simpleads-14341', 14341, 1);
</script>
<div class="simpleads-14341"></div></div></div></div></section><div class="block block-block block-39 block-block-39 even block-without-title" id="block-block-39"><div class="block-inner clearfix"><div class="content clearfix">
<script type="text/javascript">
<!--//--><![CDATA[// ><!--
google_ad_client = "ca-pub-9898940624011872";
google_ad_slot = "2640233342";
google_ad_width = 300;
google_ad_height = 600;
//--><!]]>
</script><script type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">
<!--//--><![CDATA[// ><!--
//--><!]]>
</script>
</div></div></div></div></aside></div></section> <footer id="section-footer" class="section section-footer"><div id="zone-postscript" class="zone zone-postscript clearfix container-16"><div class="grid-4 region region-postscript-second" id="region-postscript-second"><div class="region-inner region-postscript-second-inner"> <section class="block block-block block-66 block-block-66 odd" id="block-block-66"><div class="block-inner clearfix"><h2 class="block-title"><span>Advertisement</span></h2><div class="content clearfix"><div id="div-gpt-ad-1560969197571-0">
<script>
<!--//--><![CDATA[// ><!--
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1560969197571-0'); });
//--><!]]>
</script></div></div></div></section></div></div></div><div id="zone-footer-wrapper" class="zone-wrapper zone-footer-wrapper clearfix"><div id="zone-footer" class="zone zone-footer clearfix container-16"><div class="grid-24 region region-footer-first" id="region-footer-first"><div class="region-inner region-footer-first-inner"><div class="block block-block block-2 block-block-2 odd block-without-title" id="block-block-2"><div class="block-inner clearfix"><div class="content clearfix"><div class="footer1">© 2017 AL DÍA NEWS Media.</div><div class="footer2"><ul><li><a href="/pages/more/about-us/34546">ABOUT US</a></li><li><a href="/pages/more/about-us/34546">ADVERTISE</a></li><li><a href="/pages/contact-us/34560">CONTACT US</a></li><li><a href="https://aldianews.com/archive">NEWS ARCHIVE</a></li><li><a href="https://aldianews.com/pages/privacy/34559">PRIVACY</a></li><li><a href="/pages/terms-service/34543">TERMS OF SERVICE</a></li></ul></div></div></div></div></div></div></div></div></footer></div>  <div class="region region-page-bottom" id="region-page-bottom"><div class="region-inner region-page-bottom-inner"><div class="off-canvas-wrapper"><div id="off-canvas"><ul id="off-canvas-menu"><li class="first expanded menu-mlid-2836"><span title="" class="nolink">S</span><ul class="sub-nav menu-tree-mlid-2836"><li class="first last leaf menu-mlid-2761"><a href="/%3Cview%3E" title="">SEARCH</a></li></ul></li><li class="expanded menu-mlid-218"><span title="" class="nolink">☰ SECTIONS</span><ul class="sub-nav menu-tree-mlid-218"><li class="first leaf menu-mlid-5303"><a href="/videos" title="">Videos</a></li><li class="leaf menu-mlid-6792"><a href="/tags/podcast/13258" title="">Podcasts</a></li><li class="leaf menu-mlid-5302"><a href="/events" title="">AL DíA Live</a></li><li class="leaf menu-mlid-3914"><a href="/topics/politics/2" title="Politics">Politics</a></li><li class="leaf menu-mlid-3924"><a href="/topics/culture/3" title="Culture">Culture</a></li><li class="leaf menu-mlid-5257"><a href="/topics/leaders/13579" title="">Leaders</a></li><li class="leaf menu-mlid-3917"><a href="/topics/politics/education/11" title="Education">Education</a></li><li class="leaf menu-mlid-5258"><a href="/topics/culture/health/218" title="">Health</a></li><li class="leaf menu-mlid-6647"><a href="/cuentame-tellme" title="Real Life Stories of Latinos in the US">Cuéntame / Tell Me</a></li><li class="leaf menu-mlid-6652"><a href="https://aldianews.com/women-summit" title="">Women</a></li><li class="last leaf menu-mlid-5296"><a href="/american-immigrants" title="American Immigrant project Highlights Latino immigrant​s ​who ​are​ making ​Philadelphia a better place for all.">New Americans</a></li></ul></li><li class="expanded menu-mlid-838"><span title="" class="nolink">MORE</span><ul class="sub-nav menu-tree-mlid-838"><li class="first leaf menu-mlid-6642"><a href="/aldiajobs" title="">AL DIA Jobs</a></li><li class="leaf menu-mlid-5297"><a href="/pages/more/about-us/34546" title="">Advertise</a></li><li class="leaf menu-mlid-2741"><a href="/pages/more/about-us/34546">About us</a></li><li class="leaf menu-mlid-5298"><a href="/pages/contact-us/34560" title="">Contact us</a></li><li class="leaf menu-mlid-5299"><a href="/careers" title="">Careers at AL DÍA</a></li><li class="leaf menu-mlid-5300"><a href="/tips" title="">Share a News Tip</a></li><li class="leaf menu-mlid-6646"><a href="https://aldianews.com/authors/hern%C3%A1n-guaracao/394" title="">Editor In Chief&#039;s Page</a></li><li class="last leaf menu-mlid-7181"><a href="/print-edition-pricing-page" title="">Subscriptions</a></li></ul></li><li class="last expanded menu-mlid-2307"><span title="" class="nolink">CONNECT</span><ul class="sub-nav menu-tree-mlid-2307"><li class="first leaf menu-mlid-2749"><a href="https://www.facebook.com/ALDIANews" class="menu_icon menu-2749">Facebook</a></li><li class="leaf menu-mlid-2753"><a href="https://instagram.com/aldianews" class="menu_icon menu-2753">Instagram</a></li><li class="leaf menu-mlid-2750"><a href="https://twitter.com/aldianews" class="menu_icon menu-2750">Twitter</a></li><li class="last leaf menu-mlid-2755"><a href="https://www.youtube.com/user/pontealdiatv" class="menu_icon menu-2755">Youtube</a></li></ul></li></ul></div></div></div></div><script type="text/javascript">
<!--//--><![CDATA[//><!--
function euCookieComplianceLoadScripts() {}
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var eu_cookie_compliance_cookie_name = "";
//--><!]]>
</script>
<script type="text/javascript" src="https://aldianews.com/sites/default/files/js/js_Zfzg-ZIR1FauFv57FN7u8nnfC_FNvmsspwxTrppMlNI.js"></script>
</body>
</html>