<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7" xmlns:ng="http://angularjs.org"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8" xmlns:ng="http://angularjs.org"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9" xmlns:ng="http://angularjs.org"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en" class="no-js" xmlns:ng="http://angularjs.org"> <!--<![endif]-->
<head>
  <meta name="fragment" content="!">
  <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
  <meta charset="utf-8">
	<meta name="viewport" content="width=device-width, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no">
  <meta name="application-name" content="AL DÍA News" />
  <meta name="msapplication-tooltip" content="AL DÍA News" />
  <meta name="msapplication-starturl" content="http://aldianews.com/" />
  <meta name="msapplication-navbutton-color" content="#fff" />
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="http://aldianews.com/sites/default/files/ts8178znqj3awke3f0u4_400x400.png" type="image/png" />
<meta name="description" content="New Yorkers love to joke about their little cousin to the south, but Philadelphia has seriously upped its culinary in recent years and is 75 percent less likely to be referred to as “Filthy” in casual conversation among snobby New York residents." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="http://aldianews.com/articles/local/pro-tips-eating-vegetarian-philly/46530" />
<link rel="shortlink" href="http://aldianews.com/node/46530" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://aldianews.com/articles/local/pro-tips-eating-vegetarian-philly/46530" />
<meta property="og:title" content="Pro tips for eating (vegetarian) in Philly" />
<meta property="og:description" content="New Yorkers love to joke about their little cousin to the south, but Philadelphia has seriously upped its culinary in recent years and is 75 percent less likely to be referred to as “Filthy” in casual conversation among snobby New York residents." />
<meta property="og:updated_time" content="2017-03-10T02:37:52-05:00" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@aldianews" />
<meta name="twitter:url" content="http://aldianews.com/articles/local/pro-tips-eating-vegetarian-philly/46530" />
<meta name="twitter:title" content="Pro tips for eating (vegetarian) in Philly" />
<meta name="twitter:description" content="New Yorkers love to joke about their little cousin to the south, but Philadelphia has seriously upped its culinary in recent years and is 75 percent less likely to be referred to as “Filthy” in casual conversation among snobby New York residents." />
<meta property="article:published_time" content="2017-03-10T02:36:50-05:00" />
<meta property="article:modified_time" content="2017-03-10T02:37:52-05:00" />
  <title>Pro tips for eating (vegetarian) in Philly</title>
  <script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>
  <script type="text/javascript" src="//use.typekit.net/wsk8gfe.js"></script>
  <script type="text/javascript">try{Typekit.load();}catch(e){}</script>
  <link href='http://fonts.googleapis.com/css?family=Montserrat:400,700' rel='stylesheet' type='text/css'>
  <base href="/">
  <link type="text/css" rel="stylesheet" href="http://aldianews.com/sites/default/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://aldianews.com/sites/default/files/css/css_v42dqUX7kewJ22OEXuOetiDorUviZQCihodVW-P50ss.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://aldianews.com/sites/default/files/css/css_BuThHg1ZrCqWQQlQH9hwTBhDYxSsabz352ycqSSjGSY.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://aldianews.com/sites/default/files/css/css_q4XigMhHIdN7iy01Ki--mSBsw9ibyiIQ8_fULw9_K4Q.css" media="all" />

<!--[if lte IE 7]>
<link type="text/css" rel="stylesheet" href="http://aldianews.com/sites/all/themes/aldia/css/ie7.css?omkiia" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="http://aldianews.com/sites/all/themes/aldia/css/ie8.css?omkiia" media="all" />
<![endif]-->

<!--[if lte IE 9]>
<link type="text/css" rel="stylesheet" href="http://aldianews.com/sites/all/themes/aldia/css/ie9.css?omkiia" media="all" />
<![endif]-->
  <script type="text/javascript" src="http://aldianews.com/sites/default/files/js/js_gam0c92gTspMYtadSvCYU4LmcrJOl6mruic2otZm0Ic.js"></script>
<script type="text/javascript" src="http://aldianews.com/sites/default/files/js/js_H7q2xORKmR9AN8Qx5spKEIBp7R_wG2apAswJoCUZY7I.js"></script>
<script type="text/javascript" src="http://aldianews.com/sites/default/files/js/js_Uoq54dU8DAQlXOg35VLqTpIlEUQZoi7pq8qDvVbd5wE.js"></script>
<script type="text/javascript" src="http://aldianews.com/sites/default/files/js/js_dr8zclEdzsdvqNg1V4ey7RczFW2mAoJKdmMD6_E-KCk.js"></script>
<script type="text/javascript" src="http://aldianews.com/sites/default/files/js/js_8RYueyb-G-NXrUOqaXRj8KkLzWknZrL3DR7NkpoOYXM.js"></script>
<script type="text/javascript">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</script>
  <!--[if lte IE 8]>
    <script src="//cdnjs.cloudflare.com/ajax/libs/es5-shim/2.2.0/es5-shim.min.js"></script>
  <![endif]-->
  <script src="https://platform.twitter.com/widgets.js"></script>
  <script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script>
  <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

    ga('create', 'UA-746191-7', {
      'cookieDomain': 'aldianews.com',
      'siteSpeedSampleRate': 100
    });
  </script>

    <!--[if lt IE 9]>
      <script>
        document.createElement('share-button');
        document.createElement('mobile-share-buttons');
        document.createElement('dir-disqus');
      </script>
    <![endif]-->
<script src="https://use.typekit.net/bnn5vhh.js"></script>
<script>try{Typekit.load({ async: true });}catch(e){}</script>
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-46530 node-type-article i18n-en anonymous-user" >
  <div id="fb-root"></div>

    <div class="spinner-background"></div>
<div id="page_wrapper" id="ng:app" ng-app="aldia">
  <input type="checkbox" name="menu-toggle" id="menu-toggle" onclick="null" />
  <input type="checkbox" name="tools-toggle" id="tools-toggle" onclick="null" />

  <div id="mobile_menu">
    <div data-ng-controller="MenusCtrl" class="main-menu drop-menu animate-height">
      <ul class="menu" data-ng-init="mainMenu(); shortcutsMenu()" superfish>
        <li bindonce data-ng-repeat="parent_link in menu_links | orderObjectBy:'weight'" class="{{parent_link.children!=0 ? 'sub-animate-height' : 'no-children'}}" data-ng-class="{first: $first, last: $last}">
          <a data-ng-if="parent_link.link.path_alias" data-ng-class="getActive(parent_link.link.path_alias)" data-bo-href-i="/{{parent_link.link.path_alias}}">
            <span data-ng-if="parent_link.link.options.menu_icon.url" class="icon"><img data-bo-src="parent_link.link.options.menu_icon.url"></span>
            <span class="text" data-bo-text="parent_link.link.title"></span>
          </a>
          <a data-ng-if="!parent_link.link.path_alias" data-ng-class="getActive(parent_link.link.path)" data-bo-href-i="/{{parent_link.link.path}}">
            <span data-ng-if="parent_link.link.options.menu_icon.url" class="icon"><img data-bo-src="parent_link.link.options.menu_icon.url"></span>
            <span class="text" data-bo-text="parent_link.link.title"></span>
          </a>
          <ul class="second-level" data-bo-show="parent_link.children">
            <li bindonce data-ng-repeat="child_link in parent_link.children" data-ng-class="{first: $first, last: $last}">
              <a data-ng-if="child_link.link.path_alias" data-ng-class="getActive(parent_link.link.path_alias)" data-bo-href-i="/{{child_link.link.path_alias}}">
                <span data-ng-if="child_link.link.options.menu_icon.url" class="icon"><img data-bo-src="child_link.link.options.menu_icon.url"></span>
                <span class="text" data-bo-text="child_link.link.title"></span>
              </a>
              <a data-ng-if="!child_link.link.path_alias" data-ng-class="getActive(parent_link.link.path)" data-bo-href-i="/{{child_link.link.path}}">
                <span data-ng-if="child_link.link.options.menu_icon.url" class="icon"><img data-bo-src="child_link.link.options.menu_icon.url"></span>
                <span class="text" data-bo-text="child_link.link.title"></span>
              </a>
            </li>
          </ul>
        </li>

        <ul class="shortcuts" data-ng-if="shortcut_links.length">
          <div class="shortcuts-heading">{{'Shortcuts' | translate}}</div>
          <li bindonce data-ng-repeat="link in shortcut_links | orderObjectBy:'weight'" data-ng-class="{first: $first, last: $last}" class="no-children {{link.link.classes}}">
            <a data-ng-if="link.link.path_alias" data-ng-class="getActive(link.link.path_alias)" data-bo-href-i="/{{link.link.path_alias}}">
              <span data-ng-if="link.link.options.menu_icon.url" class="icon"><img data-bo-src="link.link.options.menu_icon.url"></span>
              <span class="text" data-bo-text="link.link.title"></span>
            </a>
            <a data-ng-if="!link.link.path_alias" data-ng-class="getActive(link.link.path)" data-bo-href-i="/{{link.link.path}}">
              <span data-ng-if="link.link.options.menu_icon.url" class="icon"><img data-bo-src="link.link.options.menu_icon.url"></span>
              <span class="text" data-bo-text="link.link.title"></span>
            </a>
          </li>
        </ul>
      </ul>
    </div>
  </div>

  <div id="mobile_menu_tools">
    <div data-ng-controller="MenusCtrl" class="tools-menu">
      <div class="header-content">
        <div id="block_language_switcher" data-ng-controller="MenusCtrl">
          <div class="content">
            <div data-ng-click="languageSwitcher('en')" data-ng-class="{active: language == 'en'}">Eng</div>
            <div data-ng-click="languageSwitcher('es')" data-ng-class="{active: language == 'es'}">Esp</div>
          </div>
        </div>
        <div data-ng-include="'/sites/all/themes/aldia/angular/views/menus/more-menu.html'" class="more-include"></div>
        <div data-ng-include="'/sites/all/themes/aldia/angular/views/menus/connect-menu.html'" class="connect-include"></div>
      </div>
    </div>
  </div>

  <!-- <div breakpoint id="content_wrapper" translate-dates data-ng-swipe-right="openMenu = true" data-ng-swipe-left="openMenu = false" data-ng-class="openMenu ? 'open' : ''"> -->
  <div breakpoint id="content_wrapper" translate-dates>

    <div data-ng-include="'/sites/all/themes/aldia/angular/partials/share.html'"></div>
    <div data-ng-repeat="type in ['content-header-ads']" data-ng-include="'/sites/all/themes/aldia/angular/partials/content_ad.html'"></div>
    <div data-ng-include="'/sites/all/themes/aldia/angular/partials/header.html'"></div>

    <div class="message-container"></div>

    <div class="page">
      <div data-ng-if="locationType != 'external'">
        <section class="wide main-wrapper" data-ng-view>
        </section>
      </div>
      <div data-ng-if="locationType == 'external'">
        <section class="wide main-wrapper drupal-content-container">
          <div class="main-content drupal-content-wrapper" back-end-links>
            <div class="tabs"></div>                        <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <div id="node-46530" class="node node-article node-promoted node-sticky clearfix">

  
    <div class="field field-title">
    <div class="field-item"><h1 class="heading-style-one">Pro tips for eating (vegetarian) in Philly</h1></div>
  </div>
  
  
  <div class="content">
    <div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even"><img src="http://aldianews.com/sites/default/files/styles/article_image_scaled/public/field/image/Cheesesteak_heaven.jpg?itok=5tEnLS9L" width="1131" height="645" alt="" /></div></div></div><div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even"> <p>New Yorkers love to joke about their little cousin to the south, but Philadelphia has seriously upped its culinary in recent years and is 75 percent less likely to be referred to as “Filthy” in casual conversation among snobby New Yorker residents.</p>
<p>Cara Parks, journalist from <a href="http://roadsandkingdoms.com/about/">Roads &amp; Kingdoms</a> (Winner for Best Travel Journalism Site by the Society of American Travel Writers), goes back to the city where she lived for many years and rediscovers the best places to eat and entertain: </p>
<p>She is willing to try <a href="http://zahavrestaurant.com/">Zahav,</a> Israeli cuisine in the hands of Chef Michael Solomonov. <em>Eater</em> magazine named it one of the best restaurants in the country. Here’s a <a href="https://cooking.nytimes.com/recipes/1017734-zahavs-hummus-tehina">recipe for their hummus</a>, which is known for being silky and wonderfully rich.</p>
<p>Cara Parks has also in mind <a href="http://www.stogiejoestavern.net/">Stogie Joe’s Tavern</a> where they make great upside-down square pizza, and Pizzeria Beddia.</p>
<p>Despite being know as a meat city, Roads &amp; Kingdoms made also <strong>a good selection for vegetarian dining </strong>in the City of Brotherly Love.</p>
<p>There's obviously the stand-outs like <a href="http://vedgerestaurant.com/">Vedge</a> (they have a cookbook; it's fantastic) and its cheaper, bistro off-shoot <a href="http://vstreetfood.com/">V Street</a> and <a href="http://vetriristorante.com/">Vetri</a>, with a vegetarian tasting menu, but not that cheap. </p>
<p>You can also find some fantastic Ethiopian food at <a href="https://www.yelp.com/biz/abyssinia-philadelphia">Abyssinia </a>in an atmosphere that I can confidently describe as an over-large, West Philly living room. And not to be missed: <a href="http://www.phillymag.com/restaurant/mamas-vegetarian/">Mama's Vegetarian,</a> rightly known for Mama's excellent falafel. And Lastly, <a href="http://www.missrachelspantry.com/">Miss Rachel's Pantry</a>.</p>
 </div></div></div><div class="form-item form-type-item">
  <label>Language </label>
 English
</div>
<div class="field field-name-field-topics field-type-taxonomy-term-reference field-label-above"><div class="field-label">Main Topic:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="/topics/local/6">Local</a></div></div></div><div class="field field-name-field-related-topics field-type-taxonomy-term-reference field-label-above"><div class="field-label">Related Topics:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="/topics/culture/3">Culture</a></div><div class="field-item odd"><a href="/topics/culture/cuisine/210">Cuisine</a></div><div class="field-item even"><a href="/topics/culture/social/10320">Social</a></div><div class="field-item odd"><a href="/topics/local/6">Local</a></div><div class="field-item even"><a href="/topics/local/philadelphia/15">Philadelphia</a></div></div></div><div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-above"><div class="field-label">Tags:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="/tags/veggie/11288">veggie</a></div><div class="field-item odd"><a href="/tags/food/712">food</a></div><div class="field-item even"><a href="/tags/philly/243">Philly</a></div></div></div><div class="field field-name-field-author field-type-taxonomy-term-reference field-label-above"><div class="field-label">Author:&nbsp;</div><div class="field-items"><div class="field-item even"><a href="/authors/andrea-rod-s/10279">Andrea Rodés</a></div></div></div><div class="field field-name-field-posted-date field-type-datetime field-label-above"><div class="field-label">Posted Date:&nbsp;</div><div class="field-items"><div class="field-item even"><span class="date-display-single">Friday, March 10, 2017 - 2:09am</span></div></div></div><div class="field field-name-field-media-caption field-type-text-long field-label-above"><div class="field-label">Caption:&nbsp;</div><div class="field-items"><div class="field-item even"> <div class="caption">Philly has more to offer than Cheesesteak. Photo: Wikimedia/Commons</div>
 </div></div></div>  </div>

  
  
</div>
  </div>
</div>
          </div>
        </section>
      </div>

      <div data-ng-repeat="type in ['content-bottom-ads']" data-ng-include="'/sites/all/themes/aldia/angular/partials/content_ad.html'"></div>
      <div data-ng-include="'/sites/all/themes/aldia/angular/partials/footer.html'"></div>
      <div class="overlay-mask white"></div>

    </div>
  </div>

  <div data-ng-repeat="type in ['fullscreen-popup']" data-ng-include="'/sites/all/themes/aldia/angular/partials/fullscreen_ad.html'"></div>

  <a href="#" id="goToTop"></a>

</div>

  
  <script type='text/javascript'>
    var _sf_async_config = { uid: 56838, domain: 'aldianews.com', useCanonical: false };

    /** CONFIGURATION END **/
    (function(){
      function loadChartbeat() {
        window._sf_endpt=(new Date()).getTime();
        var e = document.createElement('script');
        e.setAttribute('language', 'javascript');
        e.setAttribute('type', 'text/javascript');
        e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
        document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
         loadChartbeat : function() { oldonload(); loadChartbeat(); };
    })();
  </script>
</body>
</html>
